Back to overview
Downtime

On Going Global AWS Outage

Oct 20 at 10:18am CDT
Affected services
Blackboard
Canvas
Edgewood Express
J1 Web

Resolved
Oct 20 at 01:18pm CDT

Services are indicating that they are back and operational.

Created
Oct 20 at 10:18am CDT

We are currently experiencing disruptions affecting several key services, including Blackboard, Canvas, and others. This is due to an ongoing outage with Amazon Web Services (AWS), which is impacting a wide range of platforms, including those we depend on.

Our team is actively monitoring the situation and will provide updates as more information becomes available.