Nationwide Canvas Outage
Resolved
May 8, 2026 at 1:17pm UTC
Greetings Campus Community,
At approximately 3:30 p.m., Edgewood University was impacted by a nationwide Canvas outage stemming from a cyber security incident. Services were restored around 9:44pm last night.
Important Reminder – Stay Vigilant Against Phishing
Following incidents like this, it is common to see an increase in phishing emails that attempt to take advantage of heightened concern. Please remain cautious of unsolicited messages claiming to be related to the Canvas outage or requesting account verification.
Edgewood University will never ask you to provide your password, approve a multi-factor authentication (MFA) request you did not initiate, or share other sensitive personal information via email. Be especially wary of messages that:
• Urge immediate action or create a sense of urgency
• Ask you to click links to “restore access” or “verify your account”
• Job Offers or selling items unsolicited
• Come from external or unusual email addresses, even if they appear to be from a trusted source
If you receive a suspicious message, do not click links or open attachments. Instead, report it to the Technology Assistance Center or use the Phish Alert Report available in Outlook.
We will share additional information as it becomes available.
Thank you for your patience and understanding.
Technology Assistance Center
SysNet Operations
Office of Information Technology
608-663-6900 | edgewood.edu
Affected services
Created
May 7, 2026 at 9:25pm UTC
Greetings Campus Community,
At approximately 3:30 p.m., Edgewood University was impacted by a nationwide Canvas outage.
We are aware of the issue and are actively monitoring the situation. At this time, no action is required on your part.
Important: If Canvas prompts you to take any actions—such as clicking links, logging in, resetting your password, or completing tasks—please do not proceed. During an outage, these prompts may not be legitimate.
We will provide a follow-up notification once Canvas service is restored and will share additional information as it becomes available.
Thank you for your patience and understanding.
Technology Assistance Center
SysNet Operations
Office of Information Technology
608-663-6900 | Edgewood.edu
Affected services